LME Gateway

7.16.15.3

Released: Sep 05, 2013 File Size: 0
Package Contents:
No notes available.

Important Notes

Why Should I Upgrade?

7.16.15 Gateway resolves issues related to Account Based Risk.

System Requirements

7.16.15 Gateway resolves issues related to Account Based Risk.

Installation Notes

Enhancements

Fixes

  1. Order Server
    1. Account based SOD records generated when GTC orders placed on older versions of the gateways (7.16.7 or below) fills, will now contain a valid risk account. (Ref 220133)

Known Issues

  1. Fill Server
    1. The Fill Server might display manual fills from previous sessions if it does not process any fills over the course of the number of days configured by the "Trim-File-Interval" parameter in the AConfig Utility. (Ref 128329)

    2. Deleting bof.tbl files on the gateway can cause FIX Adapter to miss fills. (Ref 135760)

    3. The Fill Server can log :"Fill confirmation record has a sequence number (xxx) which is not valid to the internal cache. Retrieve of record failed." There are no known issues to the TT system with regards to this message, other than the logging. (Ref 201904)

  2. Order Server
    1. Order Router log time deltas might be inaccurate. (Ref 141255)

    2. An issue exists that does not allow users to execute the "Logout ITM" command in the Guardian Admin menu. (Ref 169473)

    3. The Order Server can crash if there is an exchange network disconnect. (Ref 213465)

  3. Pre-Trade Risk
    1. Account-based positions are not reset at the fills session rollover if the Order Server is running during the rollover and AutoSOD is set to false. (Ref 221856)

  4. Price Server
    1. The Price Server erroneously logs an ERROR message: "Trying to process off-tick price". (Ref 174047)

    2. The Price Server might continue attempting to log into the exchange after receiving a rejection from the exchange due to incorrect exchange credentials. In this situation, the exchange might lock the FIX session. (Ref 195967)