TT User Setup

7.17.88.13 (win64)

Released: Nov 12, 2019 File Size: 98697096
Package Contents:
No notes available.

Important Notes

TT User Setup Server is now a 64-bit application. In the ASP environment, TT upgrades the servers without any required action from our customers. For non-ASP customers, before installing the server, be aware of the following:
  • The master and slave servers cannot run different software versions.
  • You cannot upgrade directly from a 32-bit application (pre-7.17.80) to a 64-bit version. Instead you must backup the database, un-install the 32-bit version, and then install the 64-bit version.
  • The 64-bit server is compatible with older User Setup clients.
Please contact your TAM if you have questions about upgrading to this 64-bit version.

Why Should I Upgrade?

This release adds the following features:
  • Gateway Login risk now supports Price Drift Check settings for synthetic orders. Administrators can set the price drift, in ticks, allowed on child orders (based on the price of the earliest child order submitted) within rolling 1 minute, 3 minute, and Lifetime.
  • User risk now supports an additional option to the "Prevent orders that are more than X ticks" feature that supports this check on synthetic parent orders.
  • The 64-bit server is compatible with older User Setup clients.

System Requirements

This release adds the following features:
  • Gateway Login risk now supports Price Drift Check settings for synthetic orders. Administrators can set the price drift, in ticks, allowed on child orders (based on the price of the earliest child order submitted) within rolling 1 minute, 3 minute, and Lifetime.
  • User risk now supports an additional option to the "Prevent orders that are more than X ticks" feature that supports this check on synthetic parent orders.
  • The 64-bit server is compatible with older User Setup clients.

Installation Notes

The TT User Setup 7.17.88 server is ONLY compatible with TT User Setup 7.17.0.520, 7.17.10, 7.17.12, 7.17.13, 7.17.20-7.17.24. 7.17.30, 7.17.31, 7.17.40-7.17.42, 7.17.50, and 7.17.60-7.17.88 clients. The TT User Setup 7.17.88 client is not compatible with pre-7.17.88 TT User Setup servers.

To use the latest features, you should use the latest version of the client and server. Additionally, when the system is set to use two-factor authentication via SMS, all TT User Setup clients that will be used to edit user or system 2-factor authentication features must also be upgraded to 7.17.40 or higher. Clients that fail to upgrade will receive error messages or shut down when editing SMS related settings. You cannot upgrade from a 32-bit version of TT User Setup to a 64-bit version of TT User Setup. Instead, save a copy of the User Setup database, uninstall the TT User Setup servers, and then install the 32-bit version. For more information about installing TT User Setup, refer to the TT User Setup System Administration Online Help.

Enhancements

  1. Configuration
    1. Added an additional option to the User Risk section under "Prevent orders that are more than X ticks" to supports this check on synthetic parent orders. For more information, refer to the TT User Setup Help. (Ref 237294)

    2. Added Price Drift Check settings for synthetic orders to Gateway Login risk. Administrators can set the price drift, in ticks, allowed on child orders (based on the price of the earliest child order submitted) within rolling 1 minute, 3 minute, and Lifetime. Refer to the User Setup Help for more details. (Ref 237331)

Fixes

 

Known Issues