Autospreader® Strategy Engine

7.17.86.4 (win64)

Released: Jul 30, 2018 File Size: 79925056
Package Contents:
No notes available.

Important Notes

Customers that have TT API applications which connect to Synthetic SE may need to update their synthetic order handling logic before upgrading to version 7.17.2 or higher. See the "What's New in Synthetic SE 7.17.2" section of the TT API Online Help for complete details.

By default, the new dynamic connection capability is enabled beginning in Synthetic SE 7.17.x. In addition, only 64-bit packages will be made available as of 7.17.1. Before upgrading, please contact your TT Technical Account Manager for assistance in assessing your environment.

Why Should I Upgrade?

Autospreader_SE 7.17.86 is released with a new Price Display Type to support reduced ticking of the CME 2-Year Treasury Note futures, spreads, and the futures portion of covered options UDS. The Go Live date for reduced ticking on these products is Sunday, January 13 2019 (trade date Monday, January 14). The following application and Gateway versions support the reduced ticking:

- X_TRADER® 7.17.87 or higher
- X_RISK 7.17.86 or higher
- FIX Adapter 7.18.7 or higher
- TTAPI 7.17.86 or higher
- X_TRADER® API 7.17.86 or higher
- Algo SE 7.17.86 or higher
- Synthetic SE 7.17.86 or higher
- Autospreader® 7.17.86 or higher
- CME Gateway 7.18.42 or higher

System Requirements

Autospreader_SE 7.17.86 is released with a new Price Display Type to support reduced ticking of the CME 2-Year Treasury Note futures, spreads, and the futures portion of covered options UDS. The Go Live date for reduced ticking on these products is Sunday, January 13 2019 (trade date Monday, January 14). The following application and Gateway versions support the reduced ticking:

- X_TRADER® 7.17.87 or higher
- X_RISK 7.17.86 or higher
- FIX Adapter 7.18.7 or higher
- TTAPI 7.17.86 or higher
- X_TRADER® API 7.17.86 or higher
- Algo SE 7.17.86 or higher
- Synthetic SE 7.17.86 or higher
- Autospreader® 7.17.86 or higher
- CME Gateway 7.18.42 or higher

Installation Notes

TT requires all customer sites to complete a pre-installation impact analysis and network optimization before Synthetic SE is installed. TT Technical Account Managers (TAMs) will be responsible for installing and configuring Synthetic SE, as it will not be available for download on the Customer Portal.

Configuration Changes

Dynamic connections are enabled by default in 7.17.x. Before upgrading, please contact your TT Technical Account Managers for assistance in assessing your environment.

X_TRADER Version

At least X_TRADER® 7.11.4 is required to use this version of Synthetic SE. Using OCOs requires at least X_TRADER® 7.17.20.

X_RISK Version

At least X_RISK 7.12.2 is required to use this version of Synthetic SE.

Upgrading to 64-bit

If you are upgrading to this version from a 32-bit version, please see the System Administration Manual for specific procedures for upgrading to 64-bit before installing this version.

Enhancements

 

Fixes

 

Known Issues