X_TRADER®

7.17.85.4

Released: Jul 09, 2018 File Size: 0
Package Contents:
No notes available.

Important Notes


TTUpdate users, please be aware of a new TTUpdate version. Upgrading to TTUpdate version 7.17.51.2 is required, prior to installing X_TRADER® 7.17.82 and above.

X_TRADER® 7.17.80 is the minimum supported version for MiFID II compliance. For details on Customer Defaults, Algo Defaults and MiFID related updates; please refer to X_TRADER Support for MiFID II.

Why Should I Upgrade?


  • EU Config 1 Setting Enhancement: "Preventative Stop"

  • Staged Manual Fill drag-n-drop
    Added the ability to drag-n-drop fills from the OFW Orders and Fills panes into a launched Staged Order ticket or MDT; to add a Staged Manual Fill.

  • Staged Order Customer Seeding
    Added the ability to seed the preferred Customer Row, by taking the Account value that is provided on the FIX Staged Order and do a Customer Default lookup (of the executing Broker) to find a Customer match; per Market.
    Please note: a registry key is required for this functionality, please contact your TAM for the registry value.

  • TT strongly encourages all customers to upgrade to this new version.

System Requirements


  • EU Config 1 Setting Enhancement: "Preventative Stop"

  • Staged Manual Fill drag-n-drop
    Added the ability to drag-n-drop fills from the OFW Orders and Fills panes into a launched Staged Order ticket or MDT; to add a Staged Manual Fill.

  • Staged Order Customer Seeding
    Added the ability to seed the preferred Customer Row, by taking the Account value that is provided on the FIX Staged Order and do a Customer Default lookup (of the executing Broker) to find a Customer match; per Market.
    Please note: a registry key is required for this functionality, please contact your TAM for the registry value.

  • TT strongly encourages all customers to upgrade to this new version.

Installation Notes

When upgrading from existing versions, TT strongly recommends making a backup of your workspaces in a separate location.
  1. X_TRADER® 7.17.x supports workspaces from previous versions of X_TRADER® 7.17.x, 7.12.x and 7.11.x.

  2. X_TRADER® 7.17.x supports upgrades from previous versions of X_TRADER® 7.17.x, 7.12.x and 7.11.x.

  3. If your current software is older than X_TRADER® 7.11.x, TT recommends uninstalling your existing old software and performing a clean install.

Enhancements

 

Fixes

  1. MD Trader
    1. Fixed an issue where MD Trader® would incorrectly recenter after changing the Account. (Ref 236883)

Known Issues