LME Gateway

7.18.28.0

Released: Jan 11, 2018 File Size: 0
Package Contents:
No notes available.

Important Notes

LME Gateway 7.18.28 is released to resolve an issue encountered in the field.

Why Should I Upgrade?

LME Gateway 7.18.28 is released to resolve an issue encountered in the field.

The LMESelect API True/False values for Commodity Derivative Indicator were reversed so that when a user submitted an order with the Commodity Derivative Indicator set to True, the gateway would erroneously send a value of False, and vice versa. This release corrects that issue.

System Requirements

LME Gateway 7.18.28 is released to resolve an issue encountered in the field.

The LMESelect API True/False values for Commodity Derivative Indicator were reversed so that when a user submitted an order with the Commodity Derivative Indicator set to True, the gateway would erroneously send a value of False, and vice versa. This release corrects that issue.

Installation Notes

Values required when submitting orders to LME for MiFID II compliance may now be set in Customer Defaults using X_TRADERĀ® 7.17.80 and TT User Setup 7.17.84 or higher. For details on configuring the appropriate values in Customer Defaults, please refer to X_TRADERĀ® Support for MiFID II.

Full details on required fields by exchange may be found here.

Enhancements

Fixes

  1. Order Server
    1. Resolved an issue which resulted in an incorrect value being sent for Commodity Derivative Indicator. (Ref 234555)

Known Issues