LSE Gateway

7.18.25.12

Released: Nov 10, 2017 File Size: 0
Package Contents:
No notes available.

Important Notes

LSE Gateway 7.18.25 is released to support the SOLA 11 upgrade on November 13, 2017.

NOTE: Per the LSE, all GTC orders active in the market on November 10 will not be saved and Members must enter new GTC orders on SOLA 11 on November 13. Customers should remove GTC orders prior to market close on November 10.

Why Should I Upgrade?

LSE Gateway 7.18.25 is released to support the SOLA 11 upgrade on November 13, 2017. Customers must upgrade all LSE Gateways after the close on Friday, November 10th and prior to the market open on Monday, November 13.

In addition, LSE Gateway 7.18.25 is the supported version for MiFID II Compliance. For details on Customer Defaults, Algo Defaults and MiFID related updates; please refer to X_TRADER® Support for MiFID II.

NOTE: Per the LSE, all GTC orders active in the market on November 10 will not be saved and Members must enter new GTC orders on SOLA 11 on November 13. Customers should remove GTC orders prior to market close on November 10.

System Requirements

LSE Gateway 7.18.25 is released to support the SOLA 11 upgrade on November 13, 2017. Customers must upgrade all LSE Gateways after the close on Friday, November 10th and prior to the market open on Monday, November 13.

In addition, LSE Gateway 7.18.25 is the supported version for MiFID II Compliance. For details on Customer Defaults, Algo Defaults and MiFID related updates; please refer to X_TRADER® Support for MiFID II.

NOTE: Per the LSE, all GTC orders active in the market on November 10 will not be saved and Members must enter new GTC orders on SOLA 11 on November 13. Customers should remove GTC orders prior to market close on November 10.

Installation Notes

Customers who are using the TT LSE Gateway to connect to the IDEM exchange should not upgrade until IDEM conducts their upgrade to SOLA 11 on November 27th. Those who connect to both IDEM and LSE will need to split sessions onto separate gateways from November 13 - 27. Please contact your local TAM for additional details.

Values required when submitting orders to LSE as of the SOLA 11 upgrade, as well as for MiFID II compliance, may now be set in Customer Defaults using X_TRADER® 7.17.80 and TT User Setup 7.17.84. For details on configuring the appropriate values in Customer Defaults, please refer to X_TRADER® Support for MiFID II.

IMPORTANT NOTE: Null values, which are accepted by the exchange, will be automatically sent in the new MIFID fields when they are not populated by the client. Customers must ensure that these values are properly populated once required by the exchange. Full details on required fields by exchange may be found here.

Customers must either comment out or modify the ProtocolVersion parameter as follows:.

[OrderServerSession_1]
UserID=test
Password=test
ExchangeIP=test
ExchangePort=test
Member=test
ProductGroup=79
ProtocolVersion=A6

Enhancements

  1. Order Server
    1. Support new tags introduced for MiFID II (Ref 233847)

Fixes

Known Issues