TT User Setup

7.17.68.7

Released: May 03, 2016 File Size: 0
Package Contents:
No notes available.

Important Notes

This release is only applicable to TT User Setup Servers in the MultiBroker ASP environment. TT User Setup clients are not required to upgrade, but if you would like to upgrade your TT User Setup clients, please contact your TAM.

If you are currently using TT Update to manage TT Client applications and you have not already added TTUpdateEnabled=1 to the TTUserSetupServer.ini file on the TT User Setup servers, you must do so prior to upgrading. Failing to add this parameter will disable TT Update for all TT client applications.

Why Should I Upgrade?

This release fixes an issue where the User Setup Audit Trail files were appearing multiple times for a single day, and an issue where Subscriber Agreements were unavailable. This occurred only in the 7.X MultiBroker ASP environment. For information about fixes and enhancements in the previous release, refer to the TT User Setup 7.17.67 release notes.

System Requirements

This release fixes an issue where the User Setup Audit Trail files were appearing multiple times for a single day, and an issue where Subscriber Agreements were unavailable. This occurred only in the 7.X MultiBroker ASP environment. For information about fixes and enhancements in the previous release, refer to the TT User Setup 7.17.67 release notes.

Installation Notes

When TT Update is not installed on the TT User Setup client workstation, you must manually install a supported TT User Setup client. When TT Update is installed on the TT User Setup client workstation, TT Update will automatically update the TT User Setup client to match the TT User Setup server. The TT User Setup 7.17.68 server is ONLY compatible with TT User Setup 7.17.0.520, 7.17.10, 7.17.12, 7.17.13, 7.17.20-7.17.24. 7.17.30, 7.17.31, 7.17.40-7.17.42, 7.17.50, and 7.17.60-7.17.68 clients. The TT User Setup 7.17.68 client is not compatible with pre-7.17.67 TT User Setup servers.

To use the latest features, you should use the latest version of the client and server. Additionally, when the system is set to use two-factor authentication via SMS, all TT User Setup clients that will be used to edit user or system 2-factor authentication features must also be upgraded to 7.17.40 or higher. Clients that fail to upgrade will receive error messages or shut down when editing SMS related settings.

For more information about TT Update, refer to the TT Update Help. For more information about installing TT User Setup, refer to the TT User Setup System Administration Online Help.

When upgrading from previous versions that used either SMS or Email-based 2-factor authentication, users that had the "Two-factor authentication" option checked will be set to Email or SMS, based on the system-level two-factor authentication setting.
  • If the system is set to Email-based two-factor authentication at the time of upgrade, all users with the "Two-factor authentication" option checked will be set to Email.
  • If the system is set to SMS-based two-factor authentication at the time of upgrade, all users with the "Two-factor authentication" option checked will be set to SMS.
  • If the system is not configured to use two-factor authentication at the time of upgrade, all users with the "Two-factor authentication" option checked will be set to None.
When upgrading from previous versions, users that had the NYSE Liffe or OSE product group permissions allowed will be allowed or blocked as described the What's New in TT User Setup?.

Enhancements

Fixes

  1. Server
    1. Fixed an issue where the User Setup Audit Trail files were appearing multiple times for a single day. This occurred only in the 7.X MultiBroker ASP environment. (Ref 231704)

    2. Fixed an issue where Subscriber Agreements were unavailable in the MultiBroker environment. (Ref 231737)

    3. Improved perfomance related to getting and updating user information in User Setup. (Ref 232151)

Known Issues