TT User Setup

7.17.60.7

Released: Mar 16, 2015 File Size: 0
Package Contents:
No notes available.

Important Notes

If you are currently using TT Update to manage TT Client applications and you have not already added TTUpdateEnabled=1 to the TTUserSetupServer.ini file on the TT User Setup servers, you must do so prior to upgrading. Failing to add this parameter will disable TT Update for all TT client applications.

Why Should I Upgrade?

Note: When upgrading to this version from a 7.4.x version, refer to the TT User Setup 7.17.10 Release Notes for information about the features introduced in TT User Setup 7.17.10, important upgrade considerations, installation notes, enhancements, and fixes.

This release allows an environment to be set to both SMS and Email-based two-factor authentication. Previous versions only supported one option per environment. This allows an administrator to require some users to authenticate using SMS-based two-factor authentication, while requiring other users to authenticate using Email-based two-factor authentication. As with previous versions, two-factor authentication requires X_TRADER® and X_RISK 7.17.40 or higher (7.17.50 or higher is recommended when using SMS-based notification). For more information refer to the Two-Factor Authentication section of the TT User Setup Help.

Note: When the system is set to Email or SMS-based authentication, all TT User Setup clients that will be used to edit user or system 2-factor authentication features must be upgraded to 7.17.40 or later. When the system is set to use both Email and SMS two-factor authentication, all TT User Setup clients that will be used to edit user or system 2-factor authentication features must be upgraded to 7.17.60.

This release also:
  • Enforces the ICE Operator ID requirement. TT User Setup now requires an Operator ID when creating or editing a user that is assigned to an ICE Gateway Login, or when assigning an ICE Gateway Login to a user.
  • Updates the NYSE Liffe and OSE Product Groups to match the NYSE Liffe and OSE exchanges, respectively. For more information, refer to the What's New in TT User Setup? section of the TT User Setup Help.
  • Updates the Migrate Users to a New Gateway feature to also copy the Operator ID, User Level Overrides, and Exchange 1-6 fields.
  • Fixes an issue where an admin Gateway Login (an MGT with a Group of XXX) was allowed to be assigned to an MGT that shares an order book with the admin MGT, without a warning. Now TTUS prevents a user from being saved if a user with a direct trader admin login is also assigned a TTORD that is mapped to the same Member, and TTUS warns the administrator if the user with a TTORD admin login is also mapped to any direct trader.
  • Fixes an issue where Broker users in MultiBroker could not be assigned Generated Admin Gateway Logins.

System Requirements

Note: When upgrading to this version from a 7.4.x version, refer to the TT User Setup 7.17.10 Release Notes for information about the features introduced in TT User Setup 7.17.10, important upgrade considerations, installation notes, enhancements, and fixes.

This release allows an environment to be set to both SMS and Email-based two-factor authentication. Previous versions only supported one option per environment. This allows an administrator to require some users to authenticate using SMS-based two-factor authentication, while requiring other users to authenticate using Email-based two-factor authentication. As with previous versions, two-factor authentication requires X_TRADER® and X_RISK 7.17.40 or higher (7.17.50 or higher is recommended when using SMS-based notification). For more information refer to the Two-Factor Authentication section of the TT User Setup Help.

Note: When the system is set to Email or SMS-based authentication, all TT User Setup clients that will be used to edit user or system 2-factor authentication features must be upgraded to 7.17.40 or later. When the system is set to use both Email and SMS two-factor authentication, all TT User Setup clients that will be used to edit user or system 2-factor authentication features must be upgraded to 7.17.60.

This release also:
  • Enforces the ICE Operator ID requirement. TT User Setup now requires an Operator ID when creating or editing a user that is assigned to an ICE Gateway Login, or when assigning an ICE Gateway Login to a user.
  • Updates the NYSE Liffe and OSE Product Groups to match the NYSE Liffe and OSE exchanges, respectively. For more information, refer to the What's New in TT User Setup? section of the TT User Setup Help.
  • Updates the Migrate Users to a New Gateway feature to also copy the Operator ID, User Level Overrides, and Exchange 1-6 fields.
  • Fixes an issue where an admin Gateway Login (an MGT with a Group of XXX) was allowed to be assigned to an MGT that shares an order book with the admin MGT, without a warning. Now TTUS prevents a user from being saved if a user with a direct trader admin login is also assigned a TTORD that is mapped to the same Member, and TTUS warns the administrator if the user with a TTORD admin login is also mapped to any direct trader.
  • Fixes an issue where Broker users in MultiBroker could not be assigned Generated Admin Gateway Logins.

Installation Notes

When TT Update is not installed on the TT User Setup client workstation, you must manually install a supported TT User Setup client. When TT Update is installed on the TT User Setup client workstation, TT Update will automatically update the TT User Setup client to match the TT User Setup server. The TT User Setup 7.17.60 server is ONLY compatible with TT User Setup 7.17.0.520, 7.17.10, 7.17.12, 7.17.13, 7.17.20-7.17.24. 7.17.30, 7.17.31, 7.17.40-7.17.42, 7.17.50, and 7.17.60 clients. The TT User Setup 7.17.60 client is not compatible with pre-7.17.60 TT User Setup servers.

To use the latest features, you should use the latest version of the client and server. Additionally, when the system is set to use two-factor authentication via SMS, all TT User Setup clients that will be used to edit user or system 2-factor authentication features must also be upgraded to 7.17.40. Clients that fail to upgrade will receive error messages or shut down when editing SMS related settings.

For more information about TT Update, refer to the TT Update Help. For more information about installing TT User Setup, refer to the TT User Setup System Administration Online Help.

When upgrading from previous versions that used eitherSMS or Email-based 2-factor authentication, users that had the "Two-factor authentication" option checked will be set to Email or SMS, based on the system-level two-factor authentication setting.
  • If the system is set to Email-based two-factor authentication at the time of upgrade, all users with the "Two-factor authentication" option checked will be set to Email.
  • If the system is set to SMS-based two-factor authentication at the time of upgrade, all users with the "Two-factor authentication" option checked will be set to SMS.
  • If the system is not configured to use two-factor authentication at the time of upgrade, all users with the "Two-factor authentication" option checked will be set to None.
When upgrading from previous versions, users that had the NYSE Liffe or OSE product group permissions allowed will be allowed or blocked as described the What's New in TT User Setup?.

Enhancements

  1. Account
    1. Updated NYSE Liffe product group permissions to have 3 product groups: Euronext Equity and Index Derivatives, Euronext Commodities Derivatives, and Euronext Currency Derivatives. When upgrading from previous versions, if the NYSE Liffe "all products" product group was allowed, the three new product groups will be allowed as well. If the NYSE Liffe "all products" product group was blocked, the three new product groups will be blocked. Note: The three new product groups are supported on NYSE Liffe 7.17.75 and later. When connecting to older gateways, be sure to allow "all products" to continue to allow NYSE Liffe market data for the user. (Ref 230589)

  2. Client
    1. When assigning Gateway Logins to a user, ICE Gateway Logins now require an operator ID when Available to User is checked. When assigning Gateway Logins to a FIX Client, ICE Gateway Logins now require an operator ID when Available to FA User is checked. (Ref 230586)

  3. Server
    1. Updated the "Migrate Users to New Gateway" option to include the Gateway Login attributes added in 7.17 (OperatorID, User Level Overrides, and Exchange 1-6 fields). When a Gateway Flavor is specified, the "On Behalf Of" and Connection fields in the Customer Defaults also now copy and update where applicable. (Ref 230080)

    2. Added support for the new OSE "Weekly Options" product group. Products in the OSE Weekly Options product group are available on OSE Gateways 7.17.66 and later. The product group permissions for the OSE Weekly Options product group must be set to "Allow" to allow for each user that needs to to access the products in the OSE Weekly Options product group. (Ref 230330)

    3. Added an option that allows both Email and SMS two-factor authentication in the same environment (in TT User Setup 7.17.50, an environment could have either SMS or Email-based two factor authentication, but not both). (Ref 230533)

Fixes

  1. Gateway Logins
    1. Fixed an issue where an admin Gateway Login (an MGT with a group of XXX) was allowed to be assigned to an MGT that shares an order book with the admin MGT, without a warning. Now TTUS prevents a user from being saved if a user with a direct trader admin login is also assigned a TTORD that is mapped to the same Member, and TTUS warns the administrator if the user with a TTORD admin login is also mapped to any direct trader. (Ref 230060)

  2. Server
    1. Fixes an issue where Broker users in MultiBroker could not be assigned Generated Admin Gateway Logins. (Ref 230610)

Known Issues

  1. Reports
    1. Logging onto X_TRADER® increments the TT API entry in the TT Product Version/User Usage report by two. TT API should not be listed at all unless the client specifically logged into TT API. (Ref 220131)

    2. The "Most recent X_TRADER® Version" report appears to list multiple entries for the same user and IP address. However, the duplicate entry is actually the X_STUDY® version and can be disregarded. (Ref 227295)

  2. Server
    1. FIX Adapter Clients with Live login allowed and TT SIM login allowed both unchecked cannot log into FIX Adapter servers. Future versions will not require either of these checkboxes to log into FIX Adapters. The workaround is to check one of these checkboxes for FIX Adapter Clients. (Ref 222720)