Guardian

7.9.8.10

Released: Nov 01, 2013 File Size: 0
Package Contents:
No notes available.

Important Notes

Why Should I Upgrade?

This version of Guardian fixes an issue where Guardian could not download product tables if the IP of the server changed while Guardian was running.

System Requirements

This version of Guardian fixes an issue where Guardian could not download product tables if the IP of the server changed while Guardian was running.

Installation Notes


1. Customers who are currently using or planning to use TT API should ensure that Guardian 7.9.2 or higher is installed on every machine running a GuardServer. GuardServer is installed by default on most TT server products, including but not limited to the following: TT User Setup, Algo Strategy Engine, Autospreader® Strategy Engine, Synthetic Strategy Engine, Transaction Billing Server, Price Proxy, and all TT Gateways.
  • Current TT API beta customers must upgrade all GuardServers to 7.9.2 or higher at the same time, preferably over a weekend.
  • New TT API customers will need to upgrade all GuardServers to 7.9.2 or higher prior to the first instance of TT API being installed in their environment.
2. TT API is not supported in a mixed environment containing both pre-7.9.2 GuardServers and 7.9.2 or later GuardServers. Running TT API in a mixed environment will result in unpredictable license consumption behavior, which may result in X_TRADER® Pro or TT API applications not being able to obtain a license.

3. Version 7.9.2 or higher of Guardian can be installed on any TT User Setup server, version 7.4.2 or higher (Ref 169905). However, version 7.9.2 or higher of Guardian should not be installed on a TT User Setup Server if both of the following conditions are true:
  1. The TT User Setup server version is 7.4.1 or prior
  2. Enforce maximum concurrent logins is enabled in TT User Setup

Enhancements

Fixes

  1. Product Table
    1. Fixed an issue where Guardian could not download product tables if the IP of the server changed while Guardian was running. (Ref 224048)

Known Issues