TT Messaging

7.1.19.1

Released: Jun 11, 2014 File Size: 0
Package Contents:
No notes available.

Important Notes

On 5 June 2014, the OpenSSL Project issued Security Advisory CVE-2014-0224 (https://www.openssl.org/news/secadv_20140605.txt) which describes a vulnerability in the version of OpenSSL library used by previous versions of TTM. Customers using encrypted X_TRADER® Remote connections are advised to upgrade all X_TRADER® Remote Hosts to TTM 7.1.19 or higher as soon as possible to eliminate this vulnerability.

Why Should I Upgrade?

TT Messaging (TTM) 7.x provides greatly improved performance, scalability, and logging capabilities due to extensive refactoring of the TTM API and Daemon. TTM 7.x is operationally identical to previous TTM releases: TTM continues to manage queues, provide subject resolution, and use the same application semantics/wire protocol as previous versions.

TTM 7.1 adds the following functionality:
  • The TTM WAN Router is now multi-threaded, which allows TTM to take advantage of multi-core hosts.
  • The TTM WAN Router automatically configures itself for optimal use of multiple cores.

System Requirements

TT Messaging (TTM) 7.x provides greatly improved performance, scalability, and logging capabilities due to extensive refactoring of the TTM API and Daemon. TTM 7.x is operationally identical to previous TTM releases: TTM continues to manage queues, provide subject resolution, and use the same application semantics/wire protocol as previous versions.

TTM 7.1 adds the following functionality:
  • The TTM WAN Router is now multi-threaded, which allows TTM to take advantage of multi-core hosts.
  • The TTM WAN Router automatically configures itself for optimal use of multiple cores.

Installation Notes

The TTM 7.1 package may be used for new installations / upgrades of TTM WAN Routers or X_TRADER® Remote Hosts. When installing or upgrading a TTM WAN Router or Remote Host using this package, TTM 7.1 assumes no other TT applications are running on the server and auto-configures itself to maximize use of all available cores.

Enhancements

Fixes

  1. Daemon
    1. Updated TTM Daemon to include OpenSSL library v. 0.9.8za, which addresses the vulnerability described in OpenSSL Security Advisory CVE-2014-0224. (Ref 228760)

Known Issues

  1. WARNING: Guardian 7.17.0 may become disconnected from the network if Guardian administrative functions are used to start or stop the TTM WAN Router service. As an alternative, please use Guardian 7.9.x or the Services control panel module to start or stop the TTM WAN Router. This issue will be corrected in a future Guardian patch.
  2. TTM 7.x no longer supports multiple TTM WAN router and/or Remote Host processes running on a single server. A TTM server may only run a single instance of the TTM WAN Router or Remote Host daemon process.